Unstable_A11y

Experimental utility for validating accessibility at runtime. See the example below for mvp functionality.

It uses the axe-core library to perform the validations. Here is a link to the latest rules with descriptions and suggestions to fix.

Please give this component a try to see if it helps in your application, and we welcome any suggestions for how to improve.

Examples

A11y wrapper example



should violate

should not violate

API

A11y exports

You can import this module like so:

import {Unstable_A11y} from 'baseui/a11y'

It exports the following components or utility functions: